Issue creating MaxDiff surveys

Incident Report for SurveyMonkey

Resolved

This incident has been resolved.
Posted Apr 16, 2025 - 09:33 PDT

Investigating

We are aware of an issue with creating MaxDiff surveys. When the initial setup is complete, no questions are added to the survey and the option to add questions isn't working. This issue is currently under investigation.
Posted Apr 16, 2025 - 03:00 PDT
This incident affected: SurveyMonkey.