Response data missing from Analyze page

Incident Report for SurveyMonkey

Resolved

This incident has been resolved.
Posted Jun 06, 2025 - 03:56 PDT

Monitoring

We are aware of an issue that’s causing some old response data to be missing from the Analyze page. This issue is impacting NPS Tile data or Multi-Survey Analysis data that is greater than 10 years old. We have identified the cause of this issue and a solution is currently being worked on.
Posted Jun 04, 2025 - 03:09 PDT
This incident affected: SurveyMonkey.