Email errors and delays
Incident Report for SurveyMonkey
Resolved
This incident has been resolved.
Posted May 19, 2023 - 13:14 PDT
Investigating
⚠️ We're aware of an issue impacting email sending. The issue is due to an outage with a 3rd party provider and a fix is currently being implemented. There may be some delays in email sending while the fix is applied.
Posted May 19, 2023 - 11:24 PDT
This incident affected: SurveyMonkey.