Issue with viewing Maxdiff survey

Incident Report for SurveyMonkey

Resolved

This issue is now resolved
Posted Dec 06, 2024 - 08:49 PST

Investigating

We are investigating an issue that's preventing some customers from viewing or exporting the results of a Maxdiff survey
Posted Dec 06, 2024 - 02:41 PST
This incident affected: SurveyMonkey.