Error creating email invitation or reminder messages

Incident Report for SurveyMonkey

Resolved

This incident has been resolved.
Posted Oct 01, 2025 - 15:58 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 01, 2025 - 15:53 PDT

Investigating

There currently is an issue where some users may encounter an error when trying to create an email invitation or reminder message. This only affects some users. We're investigating now.
Posted Oct 01, 2025 - 15:40 PDT
This incident affected: SurveyMonkey.