NPS scores not rendering in survey Dashboards

Incident Report for SurveyMonkey

Resolved

This incident has been resolved.
Posted Mar 05, 2025 - 12:21 PST

Investigating

We are currently investigating this issue.
Posted Mar 05, 2025 - 11:15 PST
This incident affected: SurveyMonkey.