Unable to download exports from Analyze Results page
Incident Report for SurveyMonkey
Resolved
This incident has been resolved.
Posted Jan 23, 2025 - 10:27 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 23, 2025 - 10:20 PST
Identified
The issue has been identified and a fix is being implemented.
Posted Jan 23, 2025 - 10:06 PST
Investigating
⚠️ We're aware of an issue impacting the downloading of Analyze exports and we are investigating the cause.
Posted Jan 23, 2025 - 09:59 PST
This incident affected: SurveyMonkey.