Low survey completion rate for RewardsApp Surveys with Advanced-Logic

Incident Report for SurveyMonkey

Resolved

This issue has been resolved!
Posted Apr 15, 2026 - 10:20 PDT

Identified

The cause has been identified and a fix is being implemented.
Posted Apr 15, 2026 - 08:47 PDT

Investigating

We are currently investigating an issue where RewardApp surveys with advanced logic may prevent respondents from starting the survey, resulting in lower completion rates.

Our team is actively working to identify the root cause and will provide updates as more information becomes available.
Posted Apr 15, 2026 - 07:23 PDT
This incident affected: SurveyMonkey.