Error when attempting to take a survey
Incident Report for SurveyMonkey
Resolved
This incident has been resolved.
Posted Mar 11, 2024 - 10:39 PDT
Investigating
We are currently investigation an issue where an error is showing when trying to access a survey. Our team is hard at work on getting everything back up to speed, and things should be back to normal soon.
Posted Mar 11, 2024 - 10:13 PDT
This incident affected: SurveyMonkey.