Issue impacting Audience project checkout page
Incident Report for SurveyMonkey
Resolved
This incident has been resolved.
Posted Feb 18, 2023 - 21:05 PST
Identified
The issue has been identified and a fix is being implemented.
Posted Feb 18, 2023 - 21:03 PST
Investigating
We're aware of an issue impacting the Audience checkout page and our team is currently investigating the cause.
Posted Feb 18, 2023 - 19:50 PST
This incident affected: SurveyMonkey.