Some users are unable to successfully login or create an account

Incident Report for SurveyMonkey

Resolved

This incident has been resolved.
Posted Jul 03, 2025 - 11:46 PDT

Monitoring

A fix has been implemented and we're actively monitoring.
Posted Jul 03, 2025 - 10:59 PDT

Update

We are continuing to investigate this issue.
Posted Jul 03, 2025 - 09:17 PDT

Investigating

⚠️ We're aware of an intermittent issue impacting logins and sign-ups to the US site for some users, and we are investigating the cause. This doesn't impact the EU or Canadian data centres.
Posted Jul 03, 2025 - 09:02 PDT
This incident affected: SurveyMonkey.