Invalid Recaptcha error when installing an app from App Directory

Incident Report for SurveyMonkey

Resolved

This incident has been resolved.
Posted Jun 13, 2024 - 12:16 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 13, 2024 - 12:13 PDT

Identified

Issue has been identified and a fix is being worked on.
Posted Jun 13, 2024 - 12:02 PDT

Investigating

⚠️ We're aware of an issue impacting the installation of new apps (existing apps unaffected and remain operational) and we are investigating the cause.
Posted Jun 13, 2024 - 11:59 PDT
This incident affected: SurveyMonkey.