Users based in Canada having trouble exporting from Analyze Results

Incident Report for SurveyMonkey

Resolved

The issue is now resolved and all Canadian users should be able export their data without issue.
Posted Dec 05, 2024 - 13:10 PST

Investigating

We're currently aware of an issue impacting our users in Canada where Analyze Results is prevented from being able to export a survey's data. Our team is looking into the issue.
Posted Dec 05, 2024 - 12:48 PST
This incident affected: SurveyMonkey.