SurveyMonkey Reward users cannot redeem their rewards

Incident Report for SurveyMonkey

Resolved

This incident has been resolved.
Posted May 30, 2025 - 00:09 PDT

Identified

We have identified the issue, which was caused by maintenance performed by our mobile service provider. Reward redemptions are currently unavailable. We will provide updates as they become available. Thank you for your patience.
Posted May 29, 2025 - 23:30 PDT

Investigating

We are currently investigating this issue.
Posted May 29, 2025 - 23:04 PDT
This incident affected: SurveyMonkey.