Shared data pages encountering errors
Incident Report for SurveyMonkey
Resolved
This incident has been resolved.
Posted Feb 20, 2024 - 17:00 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 20, 2024 - 16:50 PST
Identified
The issue has been identified and a fix is being implemented.
Posted Feb 20, 2024 - 16:20 PST
Investigating
⚠️ We're aware of an issue impacting the individual responses tab of a shared data page (including the link we send to respondents in their confirmation email, or instant notifications to survey collaborators) and we are investigating the cause.
Posted Feb 20, 2024 - 07:00 PST
This incident affected: SurveyMonkey.