Some shared data pages cannot be accessed without the viewer logging in

Incident Report for SurveyMonkey

Resolved

This incident has been resolved.
Posted Jun 04, 2025 - 20:46 PDT

Investigating

We are currently investigating this issue.
Posted Jun 04, 2025 - 20:04 PDT
This incident affected: SurveyMonkey.