Collect page failing to load

Incident Report for SurveyMonkey

Resolved

We have resolved the issue and Collect pages are now loading for all customers.
Posted Jul 22, 2024 - 14:24 PDT

Investigating

We are investigating an issue where the Collect page is failing to load for some customers.
Posted Jul 22, 2024 - 07:06 PDT
This incident affected: SurveyMonkey.