Design page errors
Incident Report for SurveyMonkey
Resolved
This incident has been resolved.
Posted Nov 30, 2022 - 08:40 PST
Investigating
⚠️ We're aware of an issue impacting the Design page, and we are investigating the cause.
Posted Nov 30, 2022 - 08:31 PST
This incident affected: SurveyMonkey.