Users based in Canada having trouble accessing Analyze Results

Incident Report for SurveyMonkey

Resolved

This incident is now resolved. Users in Canada can now access Analyze Results as expected.
Posted Dec 04, 2024 - 13:57 PST

Investigating

We're currently aware of an issue impacting our users in Canada where Analyze Results can't be accessed. Our team is looking into the issue.
Posted Dec 04, 2024 - 10:50 PST
This incident affected: SurveyMonkey.