SurveyMonkey showing 500 errors

Incident Report for SurveyMonkey

Resolved

This issue is now resolved.
Posted Mar 25, 2026 - 08:31 PDT

Identified

A small number of customers may be seeing 500 errors when using SurveyMonkey. In most cases, these errors are cleared after refreshing the browser. Our team is aware of this issue and we are currently working on a solution.
Posted Mar 25, 2026 - 07:08 PDT
This incident affected: SurveyMonkey.