New homepage not loading for some users

Incident Report for SurveyMonkey

Resolved

This incident is resolved. There are no longer errors on the new homepage.
Posted Sep 09, 2025 - 14:55 PDT

Monitoring

Most errors have now resolved. We are continuing to monitor the incident.
Posted Sep 09, 2025 - 14:52 PDT

Identified

Our engineering team has identified an issue with the new home page not loading for some users. Users may see an error on their page instead of their surveys.
Posted Sep 09, 2025 - 14:22 PDT
This incident affected: SurveyMonkey.