Issue Impacting Exporting for Canadian SurveyMonkey Accounts

Incident Report for SurveyMonkey

Resolved

There was an issue impacting SurveyMonkey accounts hosted on our Canadian data centres, where users faced issues with exporting survey results from 10:48AM to 1:15AM (PST). This issue is now resolved and exporting should work correctly now.
Posted Jun 30, 2026 - 11:00 PDT