Incident impacting analyze and survey pages
Incident Report for SurveyMonkey
Resolved
The site is now operational.
Posted Mar 20, 2024 - 11:56 PDT
Investigating
⚠️ We're aware of an issue impacting multiple areas of the service including Analyze and the survey taking experience, and we are investigating the cause.
Posted Mar 20, 2024 - 11:46 PDT
This incident affected: SurveyMonkey.