Error showing when trying to access surveys
Incident Report for SurveyMonkey
Resolved
This issue is now resolved.
Posted Apr 09, 2024 - 09:01 PDT
Identified
We are aware of an issue where an error is showing when accessing some surveys. The cause if this issue has been identified and we are working to get everything up and running again.
Posted Apr 09, 2024 - 08:39 PDT
This incident affected: SurveyMonkey.