PowerBI syncing issues
Incident Report for SurveyMonkey
Resolved
This incident has been resolved.
Posted Mar 08, 2024 - 05:24 PST
Investigating
We're investigating an issue with syncing data to PowerBI via our PowerBI integration.

Thank you for your patience.
Posted Mar 08, 2024 - 01:58 PST
This incident affected: SurveyMonkey.