EU SurveyMonkey - Analyze Results is currently down for EU accounts
Incident Report for SurveyMonkey
Resolved
This incident has been resolved.
Posted Jan 24, 2023 - 05:50 PST
Investigating
We are currently investigating this issue.
Posted Jan 24, 2023 - 04:47 PST
This incident affected: SurveyMonkey.