Audience Preview Page create survey button is broken
Incident Report for SurveyMonkey
Resolved
This issue is now resolved
Posted Jan 09, 2024 - 09:28 PST
Investigating
The Create Survey button on the Audience preview page is not working. Clicking on this button loads a blank page. Our team is hard at work on getting everything back up to speed, and things should be back to normal soon. We apologize for the inconvenience.
Posted Jan 09, 2024 - 01:51 PST
This incident affected: SurveyMonkey.