Errors across the site and slow performance
Incident Report for SurveyMonkey
Resolved
The issue has been resolved. All services are up and running back to normal.
Posted Jan 31, 2023 - 10:07 PST
Identified
We're currently aware of an issue that is causing errors across the site. Our engineering team is currently investigating.
Posted Jan 31, 2023 - 09:11 PST