Multiple services impacted in EU
Incident Report for SurveyMonkey
Resolved
The issue has been identified & services are recovering. Survey taking and Analyze are loading.
Posted Jan 24, 2024 - 11:37 PST
Investigating
We're aware of multiple services impacted in the EU. Customers in the EU may have trouble accessing Analyze and respondents may not be able to take surveys. Our team is currently looking into the issue.
Posted Jan 24, 2024 - 11:35 PST
This incident affected: SurveyMonkey.