Issues accessing Build with AI or Billing features using mobile browser

Incident Report for SurveyMonkey

Resolved

This incident has been resolved.
Posted Aug 12, 2025 - 09:29 PDT

Investigating

When attempting to access Build with AI or Billing features using a mobile browser customers are being redirected back to the Home page. We are currently investigating this issue.
Posted Aug 12, 2025 - 08:27 PDT
This incident affected: SurveyMonkey.